Error Running CocoaPod pod install on MacOS BigSur With ffi

On MacOS Big Sur, running pod install against a simple Podfile is throwing an error in Ruby.

Podfile

LoadError – dlsym(0x7fc9ddbb5340, Init_ffi_c): symbol not found – /Library/Ruby/Gems/2.6.0/gems/ffi-1.13.1/lib/ffi_c.bundle

To get around this error. It seems you have to install ffi and disable the ffi ruby library that comes shipped with MacOS Big Sur.

sudo gem inst ffi -- --disable-system-libffi
Building native extensions with: '--disable-system-libffi'
This could take a while...
Successfully installed ffi-1.13.1
Parsing documentation for ffi-1.13.1
Done installing documentation for ffi after 3 seconds
1 gem installed

After running the command I can now run pod install successfully.

lopau

Leave a Reply

Your email address will not be published. Required fields are marked *