WordPress parse error: syntax error on PHP 5.2.x

Here is a short WordPress troubleshooting tutorial for theme tweaking.

A theme I’m working on runs fine and was tested on PHP 4.3.x locally in my machine, I tried testing on PHP 5.2.x and I immediately encountered syntax error on WordPress. Traced the problem to be inside the Loop in WordPress. Sharing it here for those having hard time making their themes work on their host.

Read the rest of this entry »